Resources‎ > ‎Laser, Rabbit‎ > ‎

Laser Design Software

Just as there is a big difference between knowing how to operate a typewriter, and knowing how to write the next great novel - there is a big gap between knowing how to operate a laser (and it's software) and designing something cool for it.

Though LaserCut (above) is required to operate the laser, it offers only minimal, "clunky" design abilities. 

LaserCut is capable of importing designs (cut paths) from a few different formats, including DXF and AI (Adobe Illustrator), and several bitmap formats which can be used for raster engraving (not for cutting paths), such as BMP, JPEG, GIF, PNG, etc.

It is highly recommended that for anything but the simplest, most primitive designs that you prepare your design in some other suitable program, and import it into LaserCut in the lab. (Aside from giving you infinitely more robust design capabilities, this frees-up usage of the laser computer for those running the laser, as opposed to drafting designs).

If you are interested in more advanced laser cutter designs, there are free resources at http://obrary.com/collections/open-designs including some examples of living hinges and other design features.

Here are some recommendations for design software to help get you started:

Sketchup

Simple drafting program - EASY learning curve, though not very powerful. More suited for 3D designs (think: 3D printer!) but works well for 2D (unless you start changing around your views in a 3d space). Free for basic use. Not extremely powerful, but good for drafting basics.

Start with a template like "Architectural Design - Millimeters" to get started quickly.

After starting: 
  1. Turn off "perspective" (or select "Parallel Projection") under "camera" menu
  2. Go to "camera->standard views->top" 
  3. Stay in "top" view - keep your designs 2d - don't do anything to make them "3d" (like "extrude"). 
To export for LaserCut:

  1. File->Export->2D Graphic
  2. Save as a "DXF" file.

Inkscape

Great, free vector graphics program. Learning curve isn't too bad, and numerous tutorials are available. I would classify this as more of an "artistic/drawing" program than an "engineering/drafting" program. Great for artistic elements, though not as good for pure "drafting" - though can be used as such - especially considering it's ease-of use. Inkscape also has tools to turn bitmaps into vector/line drawings/paths suitable for cutting. 

Inkscape is also installed on the Laser computer.

To export for LaserCut:

  1. File->Save As
  2. Select "DXF" file format
  3. Turn off checkboxes:
    1. Use ROBO-Master type of spline output (??)
    2. use LWPOLYLINE type of line output (??)
  4. Set "Base Unit" to "mm"



GIMP

Gimp is a free photo editor (similar to photoshop). I am including it here because while it is not suitable for designing cut-paths (vectors), it is well suited for preparing bitmaps for raster engraving

There are a few recommended steps in preparing any image for import into LaserCam for raster engraving.

Determine image size/resolution

Scale your image (under "Image" select "Scale Image") for a size that will be suitable for engraving on you actual work.

Some material sheets will give a perfered "DPI" for raster operations. You can enter that, but others will only list the "scan gap" setting. You can determine DPI from the "Scan Gap" setting of the material you are engraving. (See the speeds/feeds sheet for the settings for your material). 

resolution (pixels-per-inch) = 25.4 / SCAN GAP 

Or you can look it up HERE

Example: If you are engraving glass with a 0.055 scan gap - use a 461 dpi image. Wood (0.085 scan gap) would be about 300 dpi. 

Convert to Black and White
  • Adjusting brightness/contrast to obtain a "high contrast" design
  • Convert design to pure "black and white" - 1-bit (not "grey-scale") as follows:
    • Menu Image->Mode->Indexed...
    • In the dialog select "Use Black and White (1-bit) palette".
    • Conciser if you want to dither your image, to represent shades of grey as different dot patterns (see below). Different images may have very different characteristics when converting to 1-bit. This can always be finessed with adjusting the brightness and contrast of your original artwork.
Remember - The laser will turn "on" and "off" when it raster-engraves. Thus the bitmap should be "black" or "white". No color or grey. Dithering produces a "grey" effect by dithering black and white pixels.

Dithering


EXPORTING GIMP for Raster:

After converting to a 1-bit bitmap above, export your drawing in a JPG format with the menu file->export. (LaserCut often has issues with how GIMP exports BMP and PNG files - so use JPG).

These files should be impored through LaserCut's "import" option under the "file" menu.

Adobe Illustrator

Adobe Illustrator files, if saved with specific options and versions, import reliably into LaserCut. The main consideration is that all items must be Paths (including Text!), and that files must be saved in Illustrator 10 format with no special options selected.

To save as Adobe Illustrator version 10:

  1. Ensure all items have already been converted to Paths (including Text!!)
  2. Select "File -> Save As", and choose "Adobe Illustrator" as the format, and click "Save"
  3. From the Options menu that then appears:
    1. Change the Version (drop-down menu) to 10
    2. Uncheck "Compression" and "PDF" options if checked
  4. Click Save
Once saved, import the .AI file as normal into LaserCut

"PAINT"

Yea, it kind of sucks - but it has one HUGE advantage: it is simple, and well known. You can go into:

Menu -> Properties

...and enable "black and white" mode. This will make the image a true "1-bit" bitmap that LaserCut wants for raster engraving files. The prefered method of export would be to:

  • Menu: Save As->BMP Picture
  • Under "Save as type" select "Monochrome Bitmap"
  • Save as a .bmp file
This method will allow you to import your bitmap as a 1-bit file, which is the way that LaserCut wants to get it. If not, you will have to use LaserCut's "Half Bmitmap" (i.e. "Half Bitmap") function which will interpret/dither it in ways that you maybe didn't want.

Of course, paint isn't that powerful of a graphic editor - and if you would like to clean up your design ahead of time, you might want to use a program like Photoshop or GIMP (above).

Onshape

Onshape is unique in that it is a Web Based full-featured free 3D CAD program. To use it for laser work you will only want to be using a single 2D "sketch" - which can be exported/downloaded as a DXF. Big benefits include it's free, can be used from any web browser, and stores everything in the cloud for access everywhere. It is also a good "stepping stone" to get into 3D designs. Furthermore, if you are cutting pieces as components of a 3D design, this might be a better overall design paradigm. It additionally has mobile apps for both IOS and Android, so you can design on a tablet or phone if you like.

Start using Onshape

Fusion360

Fusion 360 is unique in that it is a full-featured free 3D CAD program. Similar to Onshape above, but fuller-featured, and a "donwloadable"/installable program that can run on Mac or Windows. This is a great professional-grade design tool (which seems to be trying to compete with SolidWorks). To use it for laser work you will only want to be using a single 2D "sketch" - which can be exported/downloaded as a DXF. Big benefits include it's free, and stores everything in the cloud for access everywhere. It is also a good "stepping stone" to get into 3D designs. Furthermore, if you are cutting pieces as components of a 3D design, this might be a better overall design paradigm.

Here is a step-by-step writeup on using Fusion 360 with the Laser Cutter

(If you look closely - it's not just a free "trial" - when you register, you can use indefinitely, free for hobbyists)

Get Fusion 360

Draftsight

Popular FREE version of a commercial engineering/drafting program. Definitely a steeper learning curve, but has powerful, professional design abilities - though I would not recommend if you're intent is to do heavy artistic/aesthetic design.

Other Commercial Programs

Other popular commercial programs such as:
  • AutoCAD (Drafing)
  • Adobe Illustrator (Vector Graphics)
  • Corel Draw (Vector Graphics)
  • Photoshop (Photo editor - for Raster/Engraving)
Comments