Resources‎ > ‎Laser, Rabbit‎ > ‎

Fusion 360 with Laser

Overview

Fusion 360 is a free (for hobbyists and smallish businesses) CAD/CAM software package with a lot of features:

http://www.autodesk.com/products/fusion-360/overview

While a lot of its focus is on 3D, it has great 2D features ("Sketches") that can be used for work with the Laser. Once you have it installed and running, the path to get something from a Fusion 360 Sketch into LaserCut is as follows:

1) Create the Sketch of the part you want to use
2) Save the Sketch as a DXF
3) Open the DXF in DraftSight, Inkscape, Adobe Illustrator or another program.
4) Save the DXF as an ASCII DXF (Version R12, R13 or R14 if available)
    (Or in Adobe Illustrator Version 10, if using Adobe)
5) In LaserCut, Import the new file.

There is likely some esoteric reason why Fusion360 exports in a DXF format that LaserCut can't read, and doesn't provide options for specific versions or formats. Don't know, Don't care currently, we'll figure that out eventually.

Details

Creating a Sketch in Fusion 360

There are a lot of tutorials on this, but here's the quick cheat sheet:
  1. Open Fusion 360
  2. Choose File->New Design 
  3. From the large UI icons choose "Sketch -> Create Sketch"
  4. Select the Planar Face closest to the bottom of the screen
  5. Select "Sketch->Circle->Center Diameter Circle (C)"
  6. Click on the Origin point at the middle of the screen, move the mouse to size the circle, click to end the circle.
  7. Select "Sketch->Stop Sketch"
  8. From the UI "Tree view" select and expand "Sketches"
  9. Select your Sketch, Right-click and select "Save as DXF"
For lots of tutorials on Fusion 360 see: http://fusion360.autodesk.com/learning/learning.html


Saving the file in DraftSight (Or anything else)

DraftSight is used for this task because A) It's Free,  B) It's installed on the Laser PC and C) It typically works without any extra effort for scaling correction. Feel free to try other programs and add the results here - Inkscape sort of works, but requires rescaling and other adjustments so too much annoyance. DraftSight takes 30 seconds.

  1. Open DraftSight (under Dassault Systems folder)
  2. Select "File->Save As"
  3. For the Save As type choose "R14 ASCII Drawing (*.dxf)", give your file a new name and click "Save"
The dialog looks like this:


If you're using some other program, use the R14 ASCII format as your output option in that tool as well if available. 

Saving the file in Adobe Illustrator

Adobe Illustrator, while not free, is often better at recognizing complex groupings and polylines than DraftSight or Inkscape. If you're having trouble with complex groups or outlines not showing up as expected this is a good tool to try and quite easy:

  1. Open Adobe Illustrator (MakeIt-licensed version on Laser PC)
  2. Open the DXF file and ensure it displays correctly
  3. Select "File->Save As", choose "Adobe Illustrator" as the format type and click "Save"
  4. In the Options dialog that appears, change the Version to 10, and uncheck any options
    1. Eg make sure "Compression" and "PDF" related options are UNCHECKED
  5. Click "Save"
  6. In LaserCut, choose "Import" and import the AI file created

Import the file in LaserCut

Now the fun part - use it!
  1. Open LaserCut
  2. Select "Import.."
  3. Select the DXF (or AI) you saved and click "ok"

Pro Tip: If for some reason it doesn't error but nothing displays, exit out of LaserCut and then start it again and re-try. If it still won't load, go back into DraftSight, select all components and then use "Modify-> Weld" to join the lines and re-save the DXF. LaserCut is just a pain in the butt that way.

Note that LaserCut reports the size of something imported as infinitesimally larger than the design. Eg for a circle drawn as 25.0000 in Fusion 360 and reported as 25.0000 in DraftSight it will show up in LaserCut as 25.0006:


So plan accordingly and be sure to check the sizing on anything that's super-tight tolerances. You have to account for Kerf and such anyway, so be sure to check and double-check.






Comments